Ciscoマルチセッションサンプル

Pocket
Share on LinkedIn

multisession

下記のConfigサンプルを活用頂く事で、上記のようなシチュエーションでのマルチセッションが実現できます。

特に別建てでフレッツスクエア側のDNSサーバをLAN内に構築する必要もありません。

ip name-server 123.107.190.5
ip name-server 123.107.190.6
!
!
interface FastEthernet0
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 2
 pppoe-client dial-pool-number 1
!
interface FastEthernet1
 ip address 172.16.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1414
 duplex auto
 speed auto
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
interface Dialer1
 ip address negotiated
 ip access-group EXT in
 ip mtu 1454
 ip nat outside
 ip inspect CBAC out
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname ISP@ISP.net
 ppp chap password 7 ISP_PASSWORD
 ppp ipcp dns request accept
!
interface Dialer2
 ip address negotiated
 ip access-group 3 in
 ip access-group 3 out
 ip mtu 1454
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 2
 dialer idle-timeout 0
 dialer-group 2
 ppp authentication pap callin
 ppp chap refuse
 ppp pap sent-username guest@v4flets-east.jp password 0 guest
!
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 123.107.190.0 255.255.255.0 Dialer2
ip route 220.210.194.0 255.255.255.128 Dialer2
!
ip dns server
!

ip nat inside source list NAT4Flets interface Dialer2 overload
ip nat inside source list NAT4ISP interface Dialer1 overload
!
ip access-list extended NAT4Flets
 permit ip 172.16.1.0 0.0.0.255 123.107.190.0 0.0.0.255
 permit ip 172.16.1.0 0.0.0.255 220.210.194.0 0.0.0.127
ip access-list extended NAT4ISP
 deny   ip any 123.107.190.0 0.0.0.255
 deny   ip any 220.210.194.0 0.0.0.127
 permit ip any any
!